Unable to connect to Ops Metrics or JMX Bridge
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Unable to connect to Ops Metrics or JMX Bridge

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Article ID: 293464

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Updated On:

Products

Operations Manager

Issue/Introduction

Trying to connect to the JMX Bridge, results in handshake failures

Cause

The Ops Metrics or JMX Bridge is configured to only support TLS 1.2 and the TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 cipher.  If you are connecting with a client that does not support TLS 1.2 or the TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 cipher, then the connection will fail. This will happen if you are using Java 7.

Resolution

  • The TLS version and cipher used by Ops Metrics/JMX Bridge requires the client to use Java 1.8 or newer.  Upgrade to the latest version of Java 1.8 on the client machine and check if that helps to resolve the issue.
  • If upgrading does not work, add "–J-Djava.net.debug=ssl,handshake" as a Java Version Manager (JVM) option when you start "jconsole" and review the output.  This will show details about how the JVM is connecting and performing the handshake.

Additional Information

If this information is not sufficient to resolve the problem, open a ticket with support and include this output from the JVM.