Restriction seen when setting RabbitMQ admin password for RabbitMQ tile
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Restriction seen when setting RabbitMQ admin password for RabbitMQ tile

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Article ID: 293189

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Updated On:

Products

VMware RabbitMQ

Issue/Introduction

Symptoms:

When trying to create a RabbitMQ service instance using the cf CLI command cf create-service, you may see the following error:

Creating service instance rmq_test in org build / space build-core as 
admin... 
FAILED
Server error, status code: 409, error code: 10001, message: 
Resource conflict: https://pivotal-rabbitmq-broker.somedomain.com/v2/service_instances/aa474dd5-12b1-3231-b323-1e3f34fce273a?accepts_incomplete=true

You may also see a similar error from the apps manager GUI when trying to create a service instance.

Environment


Cause

This error will prevent you from being able to create any RabbitMQ services instances.

Resolution

Review the RabbitMQ logs which can be found on each RabbitMQ node. If you encounter errors such as "Invalid credentials" as shown below, then there could be an issue with the password that is set for the admin user of the RabbitMQ cluster.

RabbitMQ Log output:

=WARNING REPORT==== 26-Jul-2016::15:23:15 ===
HTTP access denied: user 'admin' - invalid credentials
Go to Ops Manager -> RabbitMQ service tile and under the Credentials tab, verify the password for the "Server Admin Credentials" user. If the password is set or changed to include a semi-colon (;) please remove the semi-colon in the password under the Settings tab -> RabbitMQ -> "RabbitMQ admin user credentials".

Then, apply changes and you should now be able to create RabbitMQ service instances.