CB Response: Services fail to start after upgrade with error "Timeout while trying to connect to RabbitMQ "
book
Article ID: 292559
calendar_today
Updated On:
Products
Carbon Black EDR (formerly Cb Response)
Issue/Introduction
Error after Starting rabbitmq
Timeout while trying to connect to RabbitMQ
Traceback (most recent call last):
File "/usr/share/cb/virtualenv/lib/python2.7/site-packages/cb/utils/exceptions.py", line 70, in decorator
File "/usr/share/cb/virtualenv/lib/python2.7/site-packages/cb/maintenance/cbstartup/main.py", line 165, in main
File "/usr/share/cb/virtualenv/lib/python2.7/site-packages/cb/maintenance/cbstartup/main.py", line 111, in run
File "/usr/share/cb/virtualenv/lib/python2.7/site-packages/cb/maintenance/cbstartup/actions/init_rabbitmq.py", line 156, in execute
File "/usr/share/cb/virtualenv/lib/python2.7/site-packages/cb/maintenance/cbstartup/actions/init_rabbitmq.py", line 177, in _wait_for_network_connection
NetworkError: Timeout while trying to connect to RabbitMQ
Environment
CB Response Server: 6.2.x and Higher
Linux: All Supported Versions
Cause
The server cannot connect to DNS
Resolution
Communication with DNS must be re-established
As a workaround, manually start services after rabbitmq
Start Solr
sudo service cb-solr start
Start Coreservices
sudo service cb-coreservices start
Start Sensorservices
sudo service cb-sensorservices start
Start Datastore
sudo service cb-datastore start
Start Live Response
sudo service cb-liveresponse start
Start Alliance Client
sudo service cb-allianceclient start
Start Enterprised
sudo service cb-enterprised start
Start Nginx
sudo service cb-nginx start
Additional Information
If datastore fails through manual starts, verify there are no errors related to cb user credentials. If there are errors, the cb user in rabbitmq was most likely deleted and must be re-added