Event data pulled from Splunk is several days old
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Article ID: 292392
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Updated On:
Products
Carbon Black Cloud Endpoint Standard (formerly Cb Defense)
Carbon Black Cloud Enterprise EDR (formerly Cb Threathunter)
Issue/Introduction
- Splunk is configured to receive data via API from Carbon Black Cloud
- Data arrives but appears to be several days old
- There are no error messages to indicate an issue
Environment
- Carbon Black Cloud: All versions
- Carbon Black App for Splunk: 1.x
- Splunk: 8.x
Cause
- There is currently a 2,000 event limit for the VMware App for Splunk.
- When there is a large backlog of events, the app cannot receive all of the data within the normal configuration parameters.
Resolution
- In the Carbon Black App for Splunk configuration, navigate to the Alerts Inputs tab
- Select an inputs entry to edit
- Reduce the Interval for data pulls. The default is 300 seconds
- Increasing the Minimum Severity can also reduce the number of data items to pull
Feedback
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Yes
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No