App Control: API is unavailable when viewing Approval Request
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Article ID: 291688
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Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
API red dot status on Administration > System Configuration > Advanced Options > API Access Enabled
Blank User Roles when trying to edit or Create a new user.
Unable to view approvals request.
Unable to globally approve files.
Unable to view software rules page.
API log file shows the following error:
[13-Jan-2022 16:54:27 EST] API Error from page /support.php: GET <AppControlServerAddress>/api/bit9platform/v1/serverConfig/ with params {"q":"name:ShowCDCImportButtons"} with options {"81":0,"64":0,"19913":1,"42":0,"156":61000,"10023":"[removed from logging]","10022":"[removed from logging]","10015":"[removed from logging]"} returned http code 0 and result in 0.0047259330749512 seconds
[13-Jan-2022 16:54:27 EST] Last Curl error: HTTP/2 stream 0 was not closed cleanly: Unknown error code (err 8)
Environment
App Control Server: All versions
Windows Server: All Supported Versions
Cause
IPV6 is enabled in the App Control Server.
IP Adress and Domain Restrictions is enabled in IIS.
Resolution
Confirm ipv6 is enabled on the App Control Server by running the following command in an elevated command prompt: ipconfig
Do double click in IP Address and Domain Restrictions.
Click on Add Allow Entry from the action menu.
in the specific IP address enter the full IPv6 Address obtained in step 1, i.e .
fexx::xxyy:xxyy:xxyy:xxyy%12
Click ok.
Open a CMD executed as administartion enter the following command:
IISreset
Additional Information
Please note troubleshooting API issues is not an easy task and although the symptom and log entries are the same the resolution may vary between the scenarios. Please refer to 'Related Content' for more guidance.