Receive error when adding a team member: Unable to update record. One or more resources could not be added. Possibly due to security.
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Receive error when adding a team member: Unable to update record. One or more resources could not be added. Possibly due to security.

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Article ID: 29132

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When trying to add a team member to a project, an error is generated if the project finish date is in the past and the default value for the 'Availability Start' field is set to today's current date or a date later than the project finish date.
Error: Unable to update record. One or more resources could not be added. Possibly due to security.

Environment

Clarity 16.2 and above

Cause

This is working as designed. The application throws the error because the availability start date is greater than the project finish date.

Resolution

If the project finish date is in the past, ensure the default value of the 'Availability Start' field is not set to a date that is later than the project finish date.

To check the default value for the 'Availability Start' field:

  1. Log in to the application as an administrator user  
  2. Go to Administration->Studio->Objects->Team->Attributes  
  3. Click on the 'Availability Start' field
  4. If there is any default value, make sure it is not set to a date that is later than the project finish date.