App Control: Console cannot connect to SQL database after local SQL user account password change
searchcancel
App Control: Console cannot connect to SQL database after local SQL user account password change
book
Article ID: 291246
calendar_today
Updated On: 10-02-2023
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
SQL User account password has been changed in SQL Server Management Studio (SSMS) and the matching local user account on the CB Protection Server has been updated, but the console still throws the following error when you open the URL in a browser:
"The Cb Protection Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black support."
SQL Error Log has the following error message:
"Login failed for user '<user_name>'. (Microsoft SQL Server, Error: 18456)"
Environment
App Control Server: All Versions
SQL Server: All Supported Versions
Cause
The SQL User account password has not been changed in all of the CB Protection configuration files where it is stored.
Resolution
Log in to the application server where App Control Server is installed.