App Control: Console cannot connect to SQL database after local SQL user account password change
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App Control: Console cannot connect to SQL database after local SQL user account password change

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Article ID: 291246

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • SQL User account password has been changed in SQL Server Management Studio (SSMS) and the matching local user account on the CB Protection Server has been updated, but the console still throws the following error when you open the URL in a browser:
"The Cb Protection Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black support."
  • SQL Error Log has the following error message:
"Login failed for user '<user_name>'. (Microsoft SQL Server, Error: 18456)"

Environment

  • App Control Server: All Versions
  • SQL Server: All Supported Versions

Cause

The SQL User account password has not been changed in all of the CB Protection configuration files where it is stored.

Resolution

  1. Log in to the application server where App Control Server is installed.
  2. If an Agent is installed, temporarily stop & unload the Agent.
  3. Stop the App Control Server & Reporter services.
  4. Update the following configuration files with the new sa password:
Warning: Make sure the new password entered matches the existing syntax in the config files, for example: 
pwd=&quot;<NEWPASSWORDHERE>&quot;;
  • C:\Program Files (x86)\Bit9\Parity Console\API\Web.config
  • C:\Program Files (x86)\Bit9\Parity Console\WebUI\include\DataObject.ini
  • C:\Program Files (x86)\Bit9\Parity Console\WebUI\html\Dashboard\Web.config
  • C:\Program Files (x86)\Bit9\Parity Server\install.dsn
  • C:\Program Files (x86)\Bit9\Parity Server\shepherd.dsn
  • C:\Program Files (x86)\Bit9\Parity Server\WSProxy.config
  • C:\Program Files (x86)\Bit9\Parity Server\Reporter\WSProxy.config
  1. If using Connectors the following paths may also need to be updated:
  • C:\Program Files (x86)\Bit9\Integrations\CheckPoint\bin\bit9.dsn
  • C:\Program Files (x86)\Bit9\Integrations\FireEye\listener\Web.config
  1. Start the App Control Server & Reporter services.
  2. If the Agent was stopped & unloaded (step 2), load & start it now.

Additional Information

Upgrades may fail with "Carbon Black App Control database cannot be accessed." if the install.dsn has the wrong account