App Control: Certificate with specified subject not found. Agents will not be able to connect to the server
search cancel

App Control: Certificate with specified subject not found. Agents will not be able to connect to the server

book

Article ID: 290822

calendar_today

Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • After logging into the console the following error is displayed in red text across each page:
    Certificate with specified subject not found. Agents will not be able to connect to the server
  • Agents disconnected

Environment

  • App Control Server (Formerly CB Protection): All Supported Versions

Cause

This issue occurs when a user manually deletes the agent communication certificate from the Windows Trust Store on the App Control application server.
 

Resolution

  • If you have a backup of the certificate you can navigate to System Configuration > Security > Choose File in the Import Server Certificate From PKCS12 File.
  • If you do not have a backup of the certificate you can generate a new certificate using the following KB solution

Additional Information

  • To determine which certificate the App Control Server is looking for, run query:
    use das; select * from das.dbo.shepherd_configs with (nolock) where name = 'sslcertificate'