App Control: API Errors After Successful Login Using SAML
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Article ID: 290793
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Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
API pages like Software Rules, Editing Users, or moving machine policies are unavailable.
System Configuration > Advanced Options shows the API connection as failed.
Events Page shows "Your API token has expired"
Login using local accounts do not show API issues.
Environment
App Control Console: 8.1 and higher (was CB Protection)
SAML Integration
Cause
When the API checks your user permissions, it passes the entire SAML assertion as the username. For longer assertions, IIS's maximum message size is too small to fit the entire assertion.