Carbon Black Cloud: Sensor Install Hangs If Receive Segment Coalescing is Enabled
search cancel

Carbon Black Cloud: Sensor Install Hangs If Receive Segment Coalescing is Enabled

book

Article ID: 290596

calendar_today

Updated On:

Products

Carbon Black Cloud Endpoint Standard (formerly Cb Defense)

Issue/Introduction

  • Sensor install hangs
  • Sensor install log stops updating at the following point
    CA:Install: INSTALLFOLDER = C:\Program Files\Confer\
  • Receive Segment Coalescing is enabled 

Environment

  • Carbon Black Cloud Sensor: All Versions
  • Microsoft Windows: Server 2012, Server 2016

Cause

If the network interface card driver does not fully support Receive Segment Coalescing (RSC), this can cause issues with Carbon Black Cloud communications

Resolution

Disable RSC:
  1. Open a PowerShell prompt as Administrator 
  2. Run the following command
    Disable-NetAdapterRsc * 
  3. Reboot system 
  4. Open the Network Adapter properties > Advanced tab
  5. Look for the following items to be marked as disabled
    Recv Segment Coalescing (IPv4)
    Recv Segment Coalescing (IPv6)
  6. Run sensor install as normal (Attended/Unattended Install)

Additional Information

  • Install may complete over several hours if RSC is not disabled
  • Updating the NIC driver may also help alleviate the issue
  • This has been historically seen with VirtIO Nutanix but may occur in other setups if the NIC driver does not properly support RSC.