Accessing properties of an endpoint in provisioning manager gives error "Unable to connect to connector server"
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Accessing properties of an endpoint in provisioning manager gives error "Unable to connect to connector server"

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Article ID: 29056

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

Issue: Trying to access properties of an endpoint in provisioning manager, it's giving error "unable to connect to connector server".

JCS Connector server is up and running, telneting to JCS on port 20411 is successful. However, below error occurs in jcs_std_err.log

com.ca.jcs.osgi.dm.JcsOsgiBootstrapBean$2.run(JcsOsgiBootstrapBean.java:206) Caused by: javax.naming.NamingException: JCS@XXXXXXX: Failed to create

standalone configuration partition [Root exception is javax.naming.NamingException: JCS@XXXXXXXXX: Failed to create a JDBM

partition: dc=etasa [Root exception is javax.naming.NamingException [Root exception is java.io.EOFException]]]

at com.ca.jcs.standalone.StandaloneServerManager.createConfigurationPartition(StandaloneServerManager.java:706) at

com.ca.jcs.standalone.StandaloneServerManager.init(StandaloneServerManager.java:213)

 

 

 

Environment

Release:
Component: IDMGR

Cause

Cause: Missing/corrupt files under CA/IdentityManager/ConnectorServer/jcs/data/jdbm/eta

Resolution

Perform below steps to resolve the issue.

1. Stop JCS

2. Take a backup of folder CA/IdentityManager/ConnectorServer/jcs/data/jdbm/etasa

3. Delete files under folder etasa

4. Restart JCS

5. Check that the deleted files are created again

6. Verify that the endpoint properties is accessible in Provisioining Manager without any error