Carbon Black Cloud: SAML/SSO login issue 27-Jan-2021
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Carbon Black Cloud: SAML/SSO login issue 27-Jan-2021

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Article ID: 290007

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Updated On:

Products

Carbon Black Cloud Endpoint Standard (formerly Cb Defense)

Issue/Introduction

  • On attempted SAML/SSO login, user receives error
    We couldn't find that email/password, please try again.
  • URL immediately redirects from https://<DashboardURL>/login to https://<DashboardURL>/?error_code=FAIL
  • Developer Tools/Web Inspector in browser shows 401 error on GET for https://<DashboardURL>/auth/v1/sessions/current

Environment

  • Carbon Black Cloud Console: January Release (0.62 backend)
  • SAML/SSO enabled on Settings > Users
Declared incident: https://carbonblack.statuspage.io/incidents/thd21n7hrjtj

Cause

Under investigation, may be tied to case-sensitivity

Resolution

Resolution being tracked under DSER-29898

Temporary Workaround is to attempt login matching the case of the existing user account as it appears in the Carbon Black Cloud Console

Additional Information

  • If experiencing this issue, open a case with Carbon Black Technical Support and provide
    - Login URL being used
    - Email of impacted user(s)
    - Results of attempted login matching case
  • If unsure of the correct case for Admin account, also open a case and provide the first two items above