Upgrade failing on macOS devices due to missing BackendServer field in cfg.ini
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Upgrade failing on macOS devices due to missing BackendServer field in cfg.ini

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Article ID: 289980

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Updated On:

Products

Carbon Black Cloud Endpoint Standard (formerly Cb Defense) Carbon Black Cloud Enterprise EDR (formerly Cb Threathunter) Carbon Black Cloud Audit and Remediation (formerly Cb Live Ops)

Issue/Introduction

  • Sensor Update Status (SUS) job for macOS devices shows error
  • Exporting SUS job results shows error indicating no Sensor data returned
    "sensorState":"FAILED","reason":"Appservices did not return data for this sensor in this org"
  • /Applications/Confer.app/cfg.ini (pre-3.5 Sensor) OR /Library/Application\ Support/com.vmware.carbonblack.cloud/Config/cfg.ini (post-3.5 Sensor) missing BackendServer field and/or value
  • /Applications/Confer.app/cfg.ini.bkp (pre-3.5 Sensor) OR /Library/Application\ Support/com.vmware.carbonblack.cloud/Config/cfg.ini.bkp (post-3.5 Sensor) not present

Environment

  • Carbon Black Cloud Sensor: 3.5.x.x and Earlier
  • Apple macOS: All Supported Versions

Cause

Corrupted cfg.ini and missing cfg.ini.bkp

Resolution

  1. Update BackendServer in cfg.ini with Device Services URL
    BackendServer=<DeviceServices_URL>
  2. Copy cfg.ini and save as cfg.ini.bkp within /Applications/Confer.app

Additional Information

If the resolution needs to be performed on multiple devices, please open a Support case and reference EA-18372 for further assistance, providing Sensor logs from at least one impacted machine