Server upgrade fails due to package dependencies
search cancel

Server upgrade fails due to package dependencies

book

Article ID: 289836

calendar_today

Updated On:

Products

Carbon Black EDR (formerly Cb Response)

Issue/Introduction

Error when running yum-update

Error: Package: postgresql10-server-10.5-1PGDG.rhel6.x86_64 (CarbonBlack)
Requires: libicuuc.so.42()(64bit)
Error: Package: postgresql10-server-10.5-1PGDG.rhel6.x86_64 (CarbonBlack)
Requires: libicui18n.so.42()(64bit)
Error: Package: postgresql10-10.5-1PGDG.rhel6.x86_64 (CarbonBlack)
Requires: libicu
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:

Environment

  • EDR Server: All Versions

Cause

The server is missing a non-Carbon Black related yum repo to download dependencies

Resolution

The <LinuxFlavor>-Base.repo file needs to exist and contain the base, updates, extras, centosplus, and contrib mirrors listed

Additional Information

  • This is caused by an environment issue
  • Yum repos are located in /etc/yum.repos.d if wanting to compare repo contents