App Control Server Is Using the Wrong Protocol To Connect to SQL Server
book
Article ID: 289633
calendar_today
Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
Steps to correct the failed Health Indicator for SQL Server Protocol with the message:
The Carbon Black App Control Server is not connecting to SQL Server using the Shared Memory protocol.
Environment
App Control Server: All Supported Versions
Microsoft SQL Server: All Supported Versions
Single Tier Environment
Cause
The SQL Server Configuration has more than only Shared Memory enabled. According to the App Control SQL Server Configuration Guide:
In order to simplify configuration and ensure fast connectivity between the App Control server and SQL server, the App Control “Operating Environment Requirements” (OER) specifies that both products must be installed on the same machine.
When deploying the App Control in this manner, SQL Server should be configured to communicate with the App Control Server using shared memory rather than TCP/IP.
Resolution
Log in to the application server as the Carbon Black Service Account.
Stop the App Control Server and App Control Reporter services.
Open SQL Server Configuration Manager > SQL Server Network Configuration > Protocols.
Set the Protocols as follows:
Shared Memory: Enabled
Named Pipes: Disabled
TCP/IP: Disabled
Choose SQL Server Services from the left-hand pane.
Right click SQL Server > Restart to apply the changes.
Start the App Control Server and Reporter services.
Log in to the Console > settings > System Health > Infrastructure Configuration > SQL Server Protocol.
Click the refresh arrows in the corner of the right-hand pane to verify the Health Indicator has cleared.
Additional Information
The SQL Server Configuration Guide can be found on VMware Docs > Server Documentation > SQL Server Configuration Guide.
If the issue persists, the following steps may need to be taken:
Stop the App Control Server and Reporter services.
Open the file: "C:\Program Files (x86)\Bit9\Parity Server\shepherd.dsn" and verify the DRIVER= line matches:
Find the DRIVER= line and verify it matches:
DRIVER=SQL Server Native Client 11.0
Restart the SQL Server service.
Start the App Control Server and Reporter services.
Refresh the Health Indicator for the SQL Server Protocol.
If disabling TCP/IP causes console issues App Control may need to be reinstalled with the local SQL option instead of using the FQDN of the SQL Server.