App Control: Agents Are Not Connecting After Applying Server v8.9.6.5
search cancel

App Control: Agents Are Not Connecting After Applying Server v8.9.6.5

book

Article ID: 289557

calendar_today

Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Agents beginning disconnecting from Console after applying App Control Server 8.9.6.5M
  • Message similar to following reported in ServerLog.bt9 file:
(406588 ADLookup-1) Invalid parameter detected in function null. File: null Line: 0

Environment

  • App Control Agent: All Versions
  • App Control Server: Version 8.9.4+

Cause

  • The 8.9.4 version of the App Control Server introduced several issues related to AD mapping.
  • Following escalation created to address issues: EP-18123 - AD policy mapping not working after upgrade to 8.9.4

Resolution

As a workaround the Shepherd Config, AllowADScript could be used to force the "old logic" for Active Directory using vbscript:
  1. Navigate to https://<app_control_servername>/shepherd_config.php
  2. Select the property AllowADScript
  3. Change the value to true.
  4. Restart the App Control Server & Reporter services.
  5. Verify the AD accounts are able to login correctly.
Note: If AllowADScript is implemented and debugging is needed then please follow the "For App Control Server version 8.8.x and lower" instructions for debugging in the related content below.