Unable to Delete endpoints that are in a 'Pending Install' Status from the Carbon Black web console
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Unable to Delete endpoints that are in a 'Pending Install' Status from the Carbon Black web console

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Article ID: 289420

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Updated On:

Products

Carbon Black Cloud Endpoint Standard (formerly Cb Defense) Carbon Black Cloud Enterprise EDR (formerly Cb Threathunter) Carbon Black Cloud Audit and Remediation (formerly Cb Live Ops)

Issue/Introduction

Unable to Delete endpoints that are in a 'Pending Install' Status from the web console

Environment

  • Carbon Black Cloud Console

Cause

Related to identified defect:  DSER-50831

Resolution

  1. Generate a HAR Capture of the delete attempt.
  2. Log a Support ticket and include your org_id and device_id impacted

Additional Information

  • If the administrator chooses 'Delete Deregistered Assets' on the dropdown for the 'Take Action' they get a red error toast stating: "Deletion failed. Only deregistered assets can be deleted"
  • If the administrator chooses 'Uninstall Sensors' on the dropdown for the 'Take Action' they get a red error toast stating: "Sensor uninstall failed" 
  • If the administrator clicks on the trash can icon that is under the actions columns or the one in the 'Endpoint Details' row side panel. They get a red error toast stating: "Deletion failed. Only pending invitations can be deleted"
  • If the administrator clicks on the greater than icon that opens the 'Endpoint Details' row side panel. They get a red error toast stating: "No device found" but some basic information is given about the device