CB Defense: "We're unable to parse the XML message" During PingIdentify SSO Setup
search cancel

CB Defense: "We're unable to parse the XML message" During PingIdentify SSO Setup

book

Article ID: 289405

calendar_today

Updated On:

Products

Carbon Black Cloud Endpoint Standard (formerly Cb Defense)

Issue/Introduction

"We're unable to parse the XML message. SAML_211" Error when setting up Ping Identity SSO with the PSC Login 

Environment

  • CB Defense PSC Backend: All Supported Versions
  • Ping Identity: All Supported Versions

Cause

This may be caused by the ampersand's in the Url when trying to pass both the idpid and saasid at the same time

Resolution

Only pass either the idpid or the saasid as needed not both 

Additional Information

The email attribute in PingOne can also be configured using the "User Principal Name" or UPN