App Control: Agent Startup Failure Due to Citrix VDA
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Article ID: 289236
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Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
- Agent service cannot start after completing agent initialization and system reboot
- Agent may stop automatically
- Dascli commands show error "cannot connect to agent"
- The issue persists even if AV exclusions have been configured for the agent
Environment
- App Control Windows Agent: 8.x and Higher
- XenDesktop VDI
Cause
One potential cause is due to the software Citrix Virtual Delivery Agent (VDA).
Resolution
Make the changes according to the Citrix Article found
here
- Add the Key HKLM\SYSTEM\CurrentControlSet\services\CtxUvi
- Add the Value Name: HKLM\SYSTEM\CurrentControlSet\services\CtxUvi Type: REG_SZ
- Set the Values according to processes found in CB Protection Anti-Virus Exclusions
Additional Information
Citrix Virtual Delivery Agent has two editions, 32-bit and 64-bit; we've only seen the problem with the 32-bit version
Feedback
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