CB Protection: Windows OS .dlls are missing after reboot when upgrading from 7.2.3 agent to 8.X agent.
search cancel

CB Protection: Windows OS .dlls are missing after reboot when upgrading from 7.2.3 agent to 8.X agent.

book

Article ID: 289095

calendar_today

Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • After a reboot, some endpoints will fail to start Windows
  • Windows errors like: 
"mfc100u.dll" file is missing
  • Applications dependent on Windows OS .dll files have errors and cannot load/start

Environment

  • CB Protection Agent Current Version: 7.2.3.x
  • CB Protection Agent Upgrade Version: 8.x and Higher
  • Microsoft Windows: All Supported Versions
  • Microsoft Visual C++ 2010 Redistributable Package (x86)

Cause

  • Existing 7.2.3 agent installation is forcing the 8.x upgrade agent to remove the .dlls as part of the upgrade process.

Resolution

  • Unfortunately, this appears to be an issue where the damage is already done, because the broken installer for 723 is the cause and that cannot be changed
    • WORKAROUND:
      •  After doing the Agent upgrade and before reboot, run the 'Microsoft Visual C++ 2010 Redistributable Package (x86)' to reinstall the dll's back to the OS.
      • Once the DLL's are restored, the agent will not continue to delete them as it was only a 7.2.3 Installer specific defect. 
  • The permanent fix is already included in the 8.x version of the agent.

Additional Information

  • After reviewing the 7.2.3 installer data files that are dropped during installation, they confirm the installer contains the files that are being removed.
  • The fundamental difference between the 7.2.3 and 8.x installer is the Install Shield's addition of "Win\System". This means the Install Shield will put the contents of that into the system folders (contents of that folder matches the dll's that are removed)."