Server Upgrade Error Due to API Not Accessible or API Unavailable
search cancel

Server Upgrade Error Due to API Not Accessible or API Unavailable

book

Article ID: 289029

calendar_today

Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

The server upgrade does not start with an error: "API not accessible."

Environment

App Control Server: All Supported Versions

Cause

The server upgrade checks for recent API errors in the "Php_errors.log" which may not be relevant anymore.

Resolution

  1. Move the php_errors.log to the desktop
    1. In File Explorer navigate to
      \Bit9\Parity Console\WebUI\Logs\
      • Move php_errors.log to the desktop
  2. Follow the steps to validate the API & Server Communication.
  3. Re-attempt the Server upgrade.

Additional Information

  • If issues persist, capture the Server Logs for Server Upgrade Failures and open a case with Support.
  • In some instances a very large Php_errors.log file (ex: 100k lines) could slow down the Server upgrade process, so moving this file out before starting the upgrade in some instances may be beneficial.