App Control: Disconnected Agents Due to Incorrect Server ID Value
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Article ID: 289026
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Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
- Agents are showing disconnected from the App Control Console
- Dascli Status shows "Disconnected (not permitted)"
Environment
- App Control Server: All Supported Versions
- App Control Agent: All Supported Versions
- Microsoft Windows: All Versions
Cause
Agents server.id file doesn't match the App Control Server's ID value
Resolution
- Make note of the Server ID value on the App Control Server
- Go to https://<ServerName>/Support.php in a browser
- Click on Advanced Configuration tab to find the Server ID
- On the disconnected machine, browse to the follow location and compare the content of server.id file with the Server ID from the console:
- On Microsoft Windows XP/2003: Documents and Settings\All Users\Application Data\Bit9\Parity Agent\server.id
- On Microsoft Windows 7 and Higher: ProgramDATA\Bit9\Parity Agent\server.id
- If the server ID strings do not match:
- Copy the server ID from the console
- On the disconnected machine,
- Open an elevated Command Prompt as Administrator
- Change directory:
cd c:\Program Files (x86)\Bit9\Parity Agent\
- Run
dascli password <CLI PASSWORD>
dascli tamperprotect 0
- Edit the server.id file by replacing the server ID string with the server ID found on the console and save the file
- Run
dascli tamperprotect 1
dascli status
- Verify that Tamper Protection is "Enabled" and the Connection now shows "Connected" with no error
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