App Control: Disconnected Agents Due to Incorrect Server ID Value
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App Control: Disconnected Agents Due to Incorrect Server ID Value

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Article ID: 289026

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Agents are showing disconnected from the App Control Console
  • Dascli Status shows "Disconnected (not permitted)"

Environment

  • App Control Server: All Supported Versions
  • App Control Agent: All Supported Versions
  • Microsoft Windows: All Versions

Cause

Agents server.id file doesn't match the App Control Server's ID value

Resolution

  1. Make note of the Server ID value on the App Control Server
    1. Go to https://<ServerName>/Support.php in a browser
    2. ​Click on Advanced Configuration tab to find the Server ID
  1. On the disconnected machine, browse to the follow location and compare the content of server.id file with the Server ID from the console:
    • On Microsoft Windows XP/2003: Documents and Settings\All Users\Application Data\Bit9\Parity Agent\server.id
    • On Microsoft Windows 7 and Higher: ProgramDATA\Bit9\Parity Agent\server.id
  2. If the server ID strings do not match:
    1. Copy the server ID from the console
    2. On the disconnected machine,
      1. Open an elevated Command Prompt as Administrator
      2. Change directory:
cd c:\Program Files (x86)\Bit9\Parity Agent\
  1. Run
dascli password <CLI PASSWORD>
dascli tamperprotect 0
  1. Edit the server.id file by replacing the server ID string with the server ID found on the console and save the file
  2. Run
dascli tamperprotect 1
dascli status
  1. Verify that Tamper Protection is "Enabled" and the Connection now shows "Connected" with no error