CB Protection: All Agents Showing "Out of Date" After Long Period of Time
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CB Protection: All Agents Showing "Out of Date" After Long Period of Time

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Article ID: 288823

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Agents all show "Out of Date" on their CL list. 
  • Agents frequently are taking hours to pull a CL update
  • Server log contains frequent "CLStorage: Failed to rename temporary CL file" errors

Environment

  • CB Protection Server: 8.0.0 - 8.1.0

Cause

This is caused by another lock on one of the following files, causing them not to be able to rename, or upgrade:
  • ConfigList.xml
  • ConfigList.xml.enc
  • ConfigListWithDeletedItems.xml
  • ConfigListWithDeletedItems.xml.enc

Resolution

  1. Remote into the CB Protection Server. 
  2. Stop the CB Protection Server and Reporter services.
  3. Navigate to 
    C:\Program Files (x86)\Bit9\Parity Server\Hostpkg
  4. Cut the following files and place them in a backup directory outside the CB protection folder structure:
    • ConfigList.xml
    • ConfigList.xml.enc
    • ConfigListWithDeletedItems.xml
    • ConfigListWithDeletedItems.xml.enc
  5. Start the CB Protection Server and Reporter services. 
  6. Verify after 5-10 minutes that the files have been recreated.