Reporter Service Not Starting After Initial Install
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Reporter Service Not Starting After Initial Install

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Article ID: 288738

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • ParityReporter service will not start
  • Errors in Windows Event Log show a crash on KernelBase.dll
  • ParityReporter.txt contains no logs
  • Running the ParityReporter.exe manually in CMD shows a permissions error writing a .tmp file

Environment

  • App Control Server: All Supported Versions

Cause

  • This issue is cause by the service account missing permissions to write to the installation folder
  • The folder path created by the installer expects US date/time format. In other clock settings such as English (Europe) the date/time format is not parsed correctly

Resolution

  • Verify that the service account has Local Administrative Privileges
  • Verify in Local Security Policy that the account has "Logon as Service" and "Logon as Batch"
  • Set the App Control Server's clock settings to English (United States) while logged into the server as the App Control service account user.
  • Confirm "Short date" format is M/d/yyyy
  • Once permissions are applied, an uninstall and reinstall may be required