App Control: Agent Status Shows Connected (Not Permitted)
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App Control: Agent Status Shows Connected (Not Permitted)

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Article ID: 288710

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Client Registration Codes are enabled.
  • New Agent installs are not showing in the Console.
  • dascli status returns similar:
    Connection: Connected(Not Permitted)

Environment

  • App Control Agent: 8.9.2+
  • App Control Server: 8.10.0+

Cause

Agent was installed with an invalid or missing Client Registration Code.

Resolution

  1. Log in to the Console and navigate to System Configuration > Security > Registration Code Archive.
  2. Copy a Registration Code that is currently Enabled. If none are Enabled, enable one.
  3. Open a command prompt and issue the following commands:
    dascli password GlobalPassword
    dascli register code registrationcodegoeshere
  4. The Agent should return a message similar to:
    ClientId: ec6f698d-8574-11ee-99ca-0050562a73e4-c51fc8ed
  5. Allow the Agent a few minutes to connect and synchronize with the Server. Then verify the Agent has connected:
    dascli status