Carbon Black Cloud Endpoint Standard (formerly Cb Defense)
Issue/Introduction
SAML login fails for specific individual account, while other accounts successfully login
Error messages may include the following: "loginStatus":"WRONG_AUTH_METHOD", "message":"Incorrect authentication type", or multiple values with "null"
Environment
CB PSC Web Console: All Supported Versions
Cause
If other accounts are successfully able to login using SAML, then the issue is likely in the configuration of that account with the SAML provider.
Resolution
Identify a properly working account from the PSC console
Verify the configuration of the failing account matches the configuration of the properly working account with SSO provider
If the above fails, create a new account in the PSC console and create and verify configuration with SSO provider and re-attempt login
If a problem still exists, open a support ticket and include documentionation of the above items, including verification of the account with the SSO provider
Additional Information
If other accounts are not able to login and you receive the same error messages, review the troubleshooting document at the bottom.