Error: "Update Failed" With 404 Error When Saving Rapid Configs - HTTP Verbs Specified
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Error: "Update Failed" With 404 Error When Saving Rapid Configs - HTTP Verbs Specified

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Article ID: 288523

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

  • When saving a Rapid Config the error "Update Failed" is received.
  • PHP logs show a 404:
    API Error from page 415: PUT <ServerName>/api/bit9platform/restricted/rapidConfigInternal/114 with params {"enabled":true,"description":null,"settingsList":[{"id":"0","paramList":[{"param_id_unique":"7c0e87de-9a75-4f8f-b5e5-11b82718f6ec","value":"<programfilesx86>\\microsoft\\edgeupdate\\download\\*\\microsoftedge*.exe","selectedOption":""},{"param_id_unique":"d1c8ee6b-8db8-4565-bce4-35c79083e401","value":"<programfilesx86>\\microsoft\\edgeupdate\\microsoftedgeupdate.exe","selectedOption":""},{"param_id_unique":"5cee6373-7a94-41a3-b85f-55a5f116449b","value":"Microsoft *","selectedOption":""}],"policyIds":""}],"policyIds":0} with options {"81":0,"64":0,"19913":1,"42":0,"156":61000,"10023":"[removed from logging]","10022":"[removed from logging]","10015":"[removed from logging]","10036":"PUT"} returned http code 404 and result  in 0.0052969455718994 seconds
  • IIS has been harded with HTTP Verbs

Environment

  • App Control Console: All Supported Versions

Cause

Verb hardening is not supported by the App Control console

Resolution

  1. Log in to the application server hosting the Console as the Carbon Black Service Account.
  2. Launch IIS Manager
    1. Navigate to: SERVERNAME > Sites > Parity Console Web
    2. From the middle pane > IIS > Request Filtering
      • Chose the HTTP Verbs tab > Remove any verbs that are configured.
    3. Navigate to: SERVERNAME > Sites > Parity Console Web > API
    4. From the middle pane > IIS > Request Filtering
      • Choose the HTTP Verbs tab > Remove any verbs that are configured.
  3. Use an administrative command prompt to issue the command 'iisreset'

Additional Information

If the issue persists, open a case with Support and provide:

  1. Screenshot of the full Rapid Config
  2. High Debug Logs for Console Errors while recreating the issue
  3. Results from the latest Analysis Script