Error: "Update Failed" When Saving Rapid Configs
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Error: "Update Failed" When Saving Rapid Configs

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Article ID: 288523

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

When saving a Rapid Config the error "Update Failed" is received.

Environment

  • App Control Console: All Supported Versions

Cause

Typically this happens when some hardening or other restrictions have been applied to IIS.

Resolution

  1. Log in to the application server hosting the Console as the Carbon Black Service Account.
  2. Launch IIS Manager
    1. Navigate to: SERVERNAME > Sites > Parity Console Web
    2. From the middle pane > IIS > Request Filtering
      • Chose the HTTP Verbs tab > Remove any verbs that are configured.
    3. Navigate to: SERVERNAME > Sites > Parity Console Web > API
    4. From the middle pane > IIS > Request Filtering
      • Choose the HTTP Verbs tab > Remove any verbs that are configured.
  3. Use an administrative command prompt to issue the command iisreset

Additional Information

If the issue persists, open a case with Support and provide:

  1. Screenshot of the full Rapid Config
  2. High Debug Logs for Console Errors while recreating the issue
  3. Results from the latest Analysis Script