CB Protection: Error: Invalid file dsn ''
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Article ID: 288418
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Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
- Error accessing the console:
- Network error while trying to communicate with Cb Protection Server Error: Could not connect to host
- Serverlog.bt9 shows error: Connection attempt failed: General error: Invalid file dsn ''
Environment
- CB Protection Server: All Supported Versions
Cause
- Agent Cache Corruption
- CB Protection server service is unable to to access C:\Program Files (x86)\Bit9\Parity Server\shepherd.dsn
- Process Injection from another application
Resolution
- Confirm the service account used for the CB Protection server service has access to C:\Program Files (x86)\Bit9\Parity Server\shepherd.dsn
- Stop the CB Protection agent:
- https://community.carbonblack.com/t5/Knowledge-Base/CB-Protection-How-to-Stop-Start-the-Agent-Windows/ta-p/65477
- If issue stops, clear corrupted cache:
- https://community.carbonblack.com/t5/Knowledge-Base/Cb-Protection-Agent-Cache-Corruption/ta-p/44126
- If issue still persists, capture a procmon and contact CB Support.
- https://community.carbonblack.com/t5/Knowledge-Base/How-to-Collect-a-low-Altitude-Procmon-Capture/ta-p/44890
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