App Control: API Call to /v1/Computer/ Gives Error “Cannot Move Computer to Invalid Policy”
search cancel

App Control: API Call to /v1/Computer/ Gives Error “Cannot Move Computer to Invalid Policy”

book

Article ID: 288382

calendar_today

Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • API call to move policy returns error "Cannot Move Computer to Invalid Policy"

Environment

  • App Control Server: 8.8.2 and Higher
  • /api/bit9platform/v1/computer/ API

Cause

The role / user doing the api call is missing the permission "view policies"

Resolution

Add the"View Policies" permission under Gear Icon > Login Accounts