Cb Defense: How to Force Inactive Sensor to Restart by Taskkill
book
Article ID: 287484
calendar_today
Updated On:
Products
Carbon Black Cloud Endpoint Standard (formerly Cb Defense)
Issue/Introduction
Sensor gets stuck in inactive mode and cannot check in when device is online and shows a process error status
Environment
Cb Defense: Windows Sensors
Cause
Sensor can be in inactive status if Cb Defense processes cannot launch properly. It may also disable Cb Defense Tamper Protection feature in most cases and leave device unprotected.
Resolution
Steps: 1. Open Task Manager, go to "Details" tab and confirm PID of the target process (RepMgr.exe). 2. Start Command Prompt with Administrator privilege. 3. Run command: taskkill /PID {PID of the target process} 4. Process will be killed and then forced to restart, issue resolved.
Additional Information
This resolution can only help to resolve sensor inactive status caused by processes error status. If it is caused by no network, sensor removal, re-image, etc., then this KB is not related.