App Control: Unable to Load Cached Rules From the Registry
book
Article ID: 287178
calendar_today
Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
Agents are showing with a red dot status in the console after upgrade to 8.1.x
Agent health check events:
Cb Protection Agent detected a problem: Cb Protection Agent was unable to load cached rules from the registry. Enforcement from boot will be limited. Options[00000003] TotalFailures[1] FailureId[930]"
Environment
App Control Agent: 8.1.0 - 8.1.6
Microsoft Windows: All Supported Versions
Cause
This is a known issue affecting agents version 8.1.0 - 8.1.6
Resolution
Upgrade to App Control agent version 8.1.8 or Higher
Additional Information
Normal agent operation is not affected by this issue
The agent's boot enforcement changed slightly in version 8.1 and as a result a bug was discovered where the agent driver could not load some rules from the registry before the agent service starts