Redis Service is Failing to Start with error "Connection Refused"
search cancel

Redis Service is Failing to Start with error "Connection Refused"

book

Article ID: 287061

calendar_today

Updated On:

Products

Carbon Black EDR

Issue/Introduction

  • cb-redis is failing to start but the rest of the services start successfully
  • The /var/log/cb/redis/startup.out log is empty
  • Check /var/log/messages for a Redis-server segfault on cymemdeflinux_x64.so

Environment

  • Carbon Black EDR Server: Supported Versions
  • Linux OS: 6.10 and higher
  • Cylance agent installed on EDR server

Cause

If Cylance is installed, it could be scanning cb-redis causing an interop issue.

Resolution

Disable Memory Protection in Cylance

  1. Steps to Disable Memory Protection in Console:
    1. Log in to the Cylance console.
    2. Navigate to Policies > Device Policy.
    3. Click on the specific policy applied to your devices.
    4. Navigate to the Memory Actions tab.
    5. Uncheck the boxes for memory protection features (e.g., Buffer Overflow, Stack Pivot) to disable them, or set them to "Audit" instead of "Block/Terminate".
    6. Click Save to commit the changes.

Additional Information

https://home-support.cylance.com/hc/en-us