Endevor Web Services with STC pooling enabled fails with authorization error
search cancel

Endevor Web Services with STC pooling enabled fails with authorization error

book

Article ID: 28705

calendar_today

Updated On:

Products

Endevor

Issue/Introduction

When STC pooling is enabled, Endevor Web Services has specific security context requirements based on the CCI service statements configuration:

  •  If SIGNON/NOPASSCHK=SERVICE is included: The Endevor STC switches its security context to the Endevor Web Services Tomcat STC user ID during initialization. This Tomcat ID must have access to at least one Endevor Environment. If that Environment is mapped to a subsequent Environment, the Tomcat ID must also have access to the entire map route.
  • If SIGNON/NOPASSCHK=SERVICE is omitted: The STC ID itself requires access to at least one Endevor Environment. If this Environment is mapped to a subsequent Environment, the STC ID must have access to the entire map route.

This can result in the error:   
C1I0012E YOU ARE NOT AUTHORIZED TO ACCESS ANY ENDEVOR ENVIRONMENTS

Or

ACCESS DENIED FOR MAP ROUTE FROM ENVIRONMENT DEV TO ENVIRONMENT QA

Environment

All supported Endevor version

Web Services

ESI

Resolution

Provide the Web Services STC ID (or Tomcat ID) to access at least one Endevor environment,  if this Environment is mapped to a subsequent Environment,  the STC ID (or Tomcat ID) must have access to the entire map route.