App Control: No Option to Regenerate Self-Signed Certificate
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App Control: No Option to Regenerate Self-Signed Certificate

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Article ID: 287025

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

Self-signed certificate has expired, but the option to regenerate the certifcate is not available.

Environment

  • App Control Server: All Supported Versions

Cause

Strong SSL mode has been enabled for the server.

Resolution

  1. Verify that a self-signed certificate was used and not a third party certificate
  2. Revert the strong SSL setting
  3. Regenerate the App Control Server Certificate

Additional Information

  • If a third party certificate was in use, a new certificate will need to be purchased and applied
  • If all agents disconnected before the strong SSL change occured, there will not be a need to export the certificate or use dascli to reconnect agents