CB Protection: Server Address listed as NONE after server upgrade
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CB Protection: Server Address listed as NONE after server upgrade

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Article ID: 286934

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Server Address on the System Configuration > General tab shows as NONE
  • API errors making some pages inaccessible 
  • Updating the Server Address results in a "Something Went Wrong" error message

Environment

App Control Server: 8.0 and Higher

Cause

The IP Address field is missing in the Parity.ini file. 

Resolution

  1. Temporarily stop the App Control server and agent services. 
  2. Back up a copy of C:\Program Files (x86)\Bit9\Parity Console\WebUI\Include\Parity.ini in case its needed in the future
  3. Modify the file C:\Program Files (x86)\Bit9\Parity Console\WebUI\Include\Parity.ini
  4. Verify that the Server Info is listed as:
    [ServerInfo]
    protocol=http
    endpoint=127.0.0.1:41001
    IP Address=FQDN of Server
    Port=41002
    Parity Version=INSTALLED VERSION
    path="C:\Program Files (x86)\Bit9\Parity Server"
  5. Save the parity.ini file
  6. Start the App Control Server and Agent services