CB Protection: SAML Integration Returning "Identity provider did not provide an e-mail address"
book
Article ID: 286902
calendar_today
Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
Attempting to authenticate with SAML based Single Sign on returns the error: "Identity provider did not provide an e-mail address"
Environment
- CB Protection Server: 8.1.0.3324 (Patch 1) - 8.1.0.3546 (Patch 2)
- SAML Single Sign On
- EmailAddress attribute has already been added
Cause
The cause for this issue, is an unexpected namespace qualification in the specific tags below. This has been identified as EP-6650.
- KeyInfo
- Issuer
- AttributeValue
- AttributeStatement > Attribute
Resolution
Upgraded to the 8.1.4 server release.
Feedback
thumb_up
Yes
thumb_down
No