App Control: Files on Computers Missing New Files and File Prevalence Not Updating
book
Article ID: 286806
calendar_today
Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
- No new files appearing in File Catalog
- Assets > Files > Files on Computers showing no new results
- Tools > Find Files page showing no new results
- File Prevalence Not Updating
Environment
- App Control Serrver: All Supported Versions
- Microsoft SQL Server Express: All Supported Versions
Cause
- DAS database has reached/exceeded the size specified in the Shepherd Config Property, "DisableTrackingCutoffDatabaseSizeMB".
- When the size specified in "DisableTrackingCutoffDatabaseSizeMB" is reached, the Shepherd Config, "TrackFileInstances" is set to false.
Resolution
- Login to the Console
- Navigate to https://YourServer/shepherd_config.php.
- Find the Property, TrackFileInstances and confirm the Value is, currently "false".
- Find the Property, DisableTrackingCutoffDatabaseSizeMB and change the Value to 7400.
- Find the Property, TrackFileInstances and change the Value back to, "true".
- All endpoints missing file information will need to be resynced by following this process.
- Take steps to reduce the size of the das database.
Additional Information
- When installed on SQL Express DisableTrackingCutoffDatabaseSizeMB is set to 3700 by default.
- To avoid this in the future, consider upgrading the SQL Express server to SQL Standard (or higher) to avoid database size limitations:
- DisableTrackingCutoffDatabaseSizeMB can be set to 0 after upgrading to SQL Standard (or higher).
- DisableTrackingCutoffDatabaseSizeMB is default set to 0 when initially installed on SQL Standard (or higher).
Feedback
thumb_up
Yes
thumb_down
No