App Control: Console Errors After Upgrading or Installing the Server
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App Control: Console Errors After Upgrading or Installing the Server

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Article ID: 286803

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Seeing the error "something went wrong! See the error log for more details" on one or more pages
  • Unable to approve files
  • Unable to transition endpoints into different policies
  • Making changes to a user results in a "user ID x doesn't exist" error
  • PHP_error.log lists API 500 errors.
  • PHP_errors.log lists 404 errors
  • PHP errors.log lists 401 errors

Environment

  • App Control Server: All Supported Versions
  • Microsoft Windows Server: All Supported Versions

Cause

  1. Too many filters applied/corrupted Saved View. 
  2. Incorrect Service Account details.
  3. Misconfigured IIS.
  4. Incorrect API network settings.
  5. Incorrectly set API Config file.
  6. Incorrectly set Parity.ini.
  7. Temporary network/service issues.

 

Resolution

  1. Verify issue persists in Incognito/Private Browser.
  2. Verify the Carbon Black Service Account details are correct.
  3. Verify IIS has all Common Requirements enabled.
  4. Verify RPCServerAddress and WebServerAddress are stored in database correctly.
  5. Verify Connection Settings in Web.config file are correct.
  6. Confirm information contained in the ServerInfo field of \Program Files (x86)\Bit9\Parity Console\WebUI\include\parity.ini is correct, format should be as follows.
    [ServerInfo]
    protocol=http
    endpoint=127.0.0.1:41001
    IP Address=FQDN.of.server
    Port=41002
    Parity Version=<Should match server version>
    path="C:\Program Files (x86)\Bit9\Parity Server
  7. Reboot the application server to clear up possible temporary network/service issues.

Additional Information