App Control: Agent Upgrades are Failing and the Policy Status is Unprotected
search cancel

App Control: Agent Upgrades are Failing and the Policy Status is Unprotected

book

Article ID: 286786

calendar_today

Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Agent upgrades are failing. 
  • The Policy Status in Assets > Computers shows Unprotected.

Environment

  • App Control Agent: All Supported Versions
  • App Control Console: All Supported Versions
  • Microsoft Windows: All Supported Versions

Cause

This typically occurs when another process is using the Windows Installer Service.

Resolution

  1. Reboot the endpoint.
  2. If the issue persists, download the Microsoft Troubleshooter.
  3. Select Next > Installing > Carbon Black App Control Agent >  No, try other fixes