App Control: Agent Upgrade via Console Fails
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App Control: Agent Upgrade via Console Fails

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Article ID: 286751

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Agent upgrade via Console fails.
  • The Agent Upgrade log (C:\ProgramData\Bit9\ParityAgent\Logs\ParityHostAgentInstall_TIMESTAMP.log) contains:
    Failed to grab execution mutex. System error 258.
    MainEngineThread is returning 1618

Environment

  • App Control Console: All Supported Versions
  • App Control Agent: All Supported Versions
  • Microsoft Windows: All Supported Versions

Cause

  • Another installation is taking place at the same time as the upgrade was requested (Rare Event).
  • Multiple instances of msiexec.exe are running on the endpoint.

Resolution

Reboot the endpoint to be sure pending software installations have completed, and the Windows Installer Service is once again available to be used by the Agent upgrade process.

Additional Information

In some instances the Agent will show as Disconnected due to this failure during the upgrade process, but should become Connected after the reboot.