Agent Upgrade/Install Fails Due to MainEngineThread Returning 1618
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Agent Upgrade/Install Fails Due to MainEngineThread Returning 1618

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Article ID: 286751

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

During installation or upgrade the attempt fails with the following in the log:

Failed to grab execution mutex. System error 258.
MainEngineThread is returning 1618

Environment

  • App Control Agent: All Supported Versions
  • Microsoft Windows: All Supported Versions

Cause

Microsoft defines the Windows Installer Action Return Value 1618 as:

ERROR_INSTALL_ALREADY_RUNNING
Another installation is in progress. Only one installation at a time can run actions in the InstallExecuteSequence, AdminExecuteSequence, or AdvtExecuteSequence tables.

Resolution

Wait for all pending software installations to complete before re-attempting. In some instances a reboot may even be required by the Windows Installer Service for the installation(s) to complete.

Additional Information

In some instances the Agent will show as Disconnected due to this failure during the upgrade process, but should become Connected after the reboot.