HTTP Error 503 The Service Is Unavailable
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HTTP Error 503 The Service Is Unavailable

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Article ID: 286741

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

"HTTP Error 503. The service is unavailable" error displayed when accessing the web console or the Hostpkg page

Environment

  • App Control Console: All Supported Versions
  • IIS Manager: All Supported Versions

Cause

The user account (username and/or password) for one of the IIS Application Pools is incorrect

Resolution

  1. Log in to the application server as the Carbon Black Service Account.
  2. Open IIS Manager (Start > Run > inetmgr > Ok)
  3. Expand SERVERNAME > left click Application Pools
  4. Find the DefaultAppPool and AppCDownloads pools. Check the Identity being used.
    1. If the Identity Account is set to "ApplicationPoolIdentity" NO change is needed.
    2. If the Identity Account is a Carbon Black Service Account:
      1. Click on the DefaultAppPool and Select "Advanced Settings" in the right panel. 
      2. Find the Identity field, click the three dots to open the selection menu.
      3. Set the custom account, re-entering the correct credentials for the user. 
    3. Repeat the same steps for the AppCDownloads app pool. 
  5. Left click the SERVERNAME > right hand menu > Actions > Restart
  6. Verify the Application Pools remain running. If the service stops again, double check the credentials used for the service account user. 
  7. Restart the Carbon Black App Control Server service. 
  8. Verify the Console is accessible.

Additional Information

  • The four Applications pools should have the following Managed Pipeline Modes 

    .Net v4.5 Integrated
    .Net v4.5 Classic Classic
    AppCDownloads Integrated
    DefaultAppPool Integrated