HTTP Error 503 The Service Is Unavailable
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Article ID: 286741
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Updated On:
Products
Carbon Black App Control
Issue/Introduction
"HTTP Error 503. The service is unavailable" error displayed when accessing the web console or the Hostpkg page
Environment
- App Control Console: All Supported Versions
- IIS Manager: All Supported Versions
Cause
The user account (username and/or password) for one of the IIS Application Pools is incorrect
Resolution
- Log in to the application server as the Carbon Black Service Account.
- Open IIS Manager (Start > Run > inetmgr > Ok)
- Expand SERVERNAME > left click Application Pools
- Find the DefaultAppPool and AppCDownloads pools. Check the Identity being used.
- If the Identity Account is set to "ApplicationPoolIdentity" NO change is needed.
- If the Identity Account is a Carbon Black Service Account:
- Click on the DefaultAppPool and Select "Advanced Settings" in the right panel.
- Find the Identity field, click the three dots to open the selection menu.
- Set the custom account, re-entering the correct credentials for the user.
- Repeat the same steps for the AppCDownloads app pool.
- Left click the SERVERNAME > right hand menu > Actions > Restart
- Verify the Application Pools remain running. If the service stops again, double check the credentials used for the service account user.
- Restart the Carbon Black App Control Server service.
- Verify the Console is accessible.
Additional Information
- The four Applications pools should have the following Managed Pipeline Modes
.Net v4.5 |
Integrated |
.Net v4.5 Classic |
Classic |
AppCDownloads |
Integrated |
DefaultAppPool |
Integrated |
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