App Control: Updating SAML IDP configuration in console causes an error when saving.
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App Control: Updating SAML IDP configuration in console causes an error when saving.

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Article ID: 286688

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

Attempting to update any part of the IDP configuration will cause the following error in the PHPErrors.log file when saving:
API Error from page 602: POST<REDACTED>/api/bit9platform/restricted/identityProvider/ with params {"name":"Login with SSO","entityId":"https:\/\/<REDACTED>","signonBinding":"urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect","signonLocation":"https:\/\/<REDACTED>\/idp\/SSO.saml2","logoutBinding":"urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect","logoutLocation":"","signingCert":"<CERT ID HERE>","encryptionCert":"","id":"1"} with options {"81":0,"64":0,"19913":1,"42":0,"156":61000,"10023":"[removed from logging]","10022":"[removed from logging]","10015":"[removed from logging]"} returned http code 400 and result ["Cannot insert the value NULL into column 'as_string', table 'das.dbo.certificate_binary'; column does not allow nulls. INSERT fails.\r\nThe statement has been terminated."] in 0.02717399597168 seconds.

Environment

  • App Control Server: 8.9.0 - 8.10.0
  • SAML Integration with IDP (Identity Provider)

Cause

This issue was identified as a defect and tracked under EP-20278.

Resolution

EP-20278 was resolved with the release of Server 8.10.2.

Additional Information

Workaround: Delete the existing IDP and re-add it to the App Control console. The NULL value error is not an issue when it is applied as a new entry instead of an update to existing values.