Cannot Connect to User Agent
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Article ID: 286658
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Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Environment
- App Control Agent: All Supported Versions
- Microsoft Windows: All Supported Versions
Cause
This message is returned when the Agent service is not currently running. Typically this happens when:
- Agent service is Stopped, Restarting, or Disabled.
- Another software program injecting itself into the Agent, and not allowing the service to fully start.
- The installation has become corrupted.
Resolution
Typically this can be resolved with a reboot of the endpoint. However, if this does not work:
- Verify Antivirus Exclusions for the Agent are in place for any other security product.
- Click Start > Run > services.msc > Ok and locate the service, Carbon Black App Control Agent.
- Attempt to manually upgrade the Agent to the latest version.
- Verify the Startup Type is set to Automatic and verify the status is Running.
Additional Information
- By default the Agent service has the start type "auto" and the Agent driver has the start type "boot".
- The following commands in an administrative command prompt will set the Driver and Service accordingly:
sc config parity start= auto
sc config paritydriver start= boot
- The following administrative Windows commands can be used:
Verify service status: sc query parity
Verify driver status: sc query paritydriver
Verify paritydriver is loaded: fltmc
Verify paritydriver instances: fltmc instances
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