App Control: Alerts and Email Alerts not Triggering
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Article ID: 286623
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Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
Alerts are not triggering.
Emails for Alerted Events are not sending.
AlertExecute scheduled task last run time, is over 24 hours prior
Environment
App Control Server: All Supported Versions
Cause
AlertExecute and AlertGetNotifications are in an Execution Group with other tasks. If the other tasks take too long to complete, it will restart the whole group, causing the later tasks to not start until the previous ones complete.
Resolution
Move the AlertExecute and AlertGetNotifications tasks into their own Execution Group:
Login to the application server hosting the Console as the Service Account and stop the services: App Control Server and App Control Reporter.
Using SQL Management Studio run the following against the DAS database:
use das;
update dbo.scheduled_tasks set execution_group = 'alerts' where task = 'AlertExecute'
update dbo.scheduled_tasks set execution_group = 'alerts' where task = 'AlertGetNotifications'
Start the services: App Control Server and App Control Reporter