Remote Desktop Login Failures With Agent Installed On Server 2022
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Article ID: 286586
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Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
Limited hardware resources and/or multiple security products running on the same box exposes or worsens the issue.
Attempts to log in via Remote Desktop Fail with the error:
Your Remote Desktop Services session has ended, possibly for one of the following reasons:
The administrator has ended the session.
An error occurred while the connection was being established
A network problem occurred.
For help solving the problem, see "Remote Desktop" in Help and Support.
Windows Event Viewer Application Log shows the dwm.exe process registering and exiting several times:
Level: Information
Source: Desktop Window Manager
Event ID: 9027
The Desktop Window Manager has registered the session port.
Level: Warning
Source: Dwminit
Event ID: 0
The Desktop Window Manager process has exited. (Process exit code: 0x800401f0, Restart count: 8, Primary display device ID: )
Environment
App Control Agent: All Supported Versions
Microsoft Window Server 2022: All Supported Versions
Cause
Race condition with the Dwm.exe process and rpcss.dll
Resolution
Carbon Black has determined that this issue is not ultimately caused by App Control. It is recommend to contact Microsoft support for additional assistance with the Race Condition on dwn.exe and rpcss.dll. In the meantime changes in Agent version 8.9.2+ will help reduce the chances of this Race Condition.
Customers running 8.8.x - 8.9.0 have reported higher rates of failure. It is highly recommended to contact Microsoft Support regarding this Race Condition and request additional assistance. In the meantime, Carbon Black Support has found a few workarounds that may help reduce the chance of encountering this race condition.