Upgrade to Server Version 8.10.4 and Higher Takes Very Long Time To Complete
search cancel

Upgrade to Server Version 8.10.4 and Higher Takes Very Long Time To Complete

book

Article ID: 286569

calendar_today

Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

During a Server upgrade to version 8.10.4+ the step Executing 'migrate'. Please wait... seems stuck, but the time elapsed continues to count up.

Environment

  • App Control Server: 8.10.2+

Cause

The initial upgrade to Server version 8.10.2/8.10.4 and higher require a table restructure during the upgrade process; this causes a longer than usual upgrade time.

  • EP-19460: Changed how we store Yara Tags associated with file instances to improve query performance and to significantly reduce disk storage usage.

Resolution

The upgrade time is highly variable and is dependent on the number of antibody instances, the count of yara tags, and the SQL resources.

If already on Server version 8.9.4+, Support could provide a manual script to perform the table transformation. For some customers this could be 2-3 times faster than the normal upgrade. Please open a support case to request more information.

Additional Information

  • Warnings were included in the Release Notes regarding the potential for this increased upgrade time.
  • The What's Running Now script can be used to monitor the Individual Query changes and overall duration of this step.
    • The Status column showing "Suspended" is not a cause for concern.
  • Delaying the upgrade will potentially increase the time it takes to complete due to additional Yara tag and file associations.
  • Some customers have reported upgrade times ranging from 1 hour to as extreme as 36+ hours.
  • During this time it may be necessary to either Change Enforcement Level (Locally) for some Agents or use the dascli abstate command to manually issue a Local Approval for some files.