App Control: Intermittent Slow Console Performance
search cancel

App Control: Intermittent Slow Console Performance

book

Article ID: 286537

calendar_today

Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • The App Control Console will become unresponsive after performing certain actions.
  • This may not always be easily reproducible.
  • Restarting IIS resolves the issue for a short period

Environment

  • App Control Server: All Supported Versions
  • Microsoft Windows Server: All Supported Versions

Cause

IIS does not have enough Private Memory allocated in order to handle the queries generated by the Server.

Resolution

Verify any Private Memory restriction for the DefaultAppPool has been removed:
  1. Log in to the application server hosting the Console as the Carbon Black Service Account.
  2. Launch IIS Manager (Start > inetmgr).
  3. From the left-hand pane expand the server name > select Application Pools > right click DefaultAppPool > Recycling
  4. Adjust the Private memory usage (in KB) to: 0 > click Next > Finish.
  5. From the left-hand pane > select the server name.
  6. From the right-hand pane > Actions > Restart.

Additional Information

  • In some instances missing the functional fixes included with the SQL Server Cumulative Updates can lead to performance issues.
  • Additional improvements (EP-20097) will be included in Server 8.10.2.