Troubleshoot Agent Package Generation Failures
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Troubleshoot Agent Package Generation Failures

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Article ID: 286510

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

Troubleshoot cases where Agent Package Generations are failing. This presents itself when https://ServerAddress/InstallerVersions.php

  • Version Installed: Contains a version when Package Generation is Enabled.
  • Package Generation Status: Returns to Disabled after being set to Enabled.

Environment

  • App Control Server: All Supported Versions

Cause

Package Generation will automatically turn off under two common scenarios:

  • The Unbranded Installer file is missing/was deleted (Ex: ParityHostAgent.msi) 
  • Sharing Violations are occurring on the files during Package Generation

Resolution

Initial Troubleshooting:

  1. Install the Agent Installer certificates locally & re-install the relevant Agent Host Package Installer locally.
  2. Verify each of the following:
  3. Delete the temp files from the Service Account local temp and Server's local temp directories.
  4. Manually test Regenerating Policy Installers.

 

Manually Test Regenerating Policy Installers:

  1. Log in to the Console and navigate to: https://ServerAddress/shepherd_config.php
  2. Set the problematic Package Generation task to true:
    GenerateWindowsInstaller
    GenerateMACInstaller
    GenerateRedhatInstaller
  3. Navigate to https://ServerAddress/support.php > Advanced Configuration > click Regenerate install files.
  4. Monitor the /hostpkg/ page to see if the links disappear, or the Shepherd Config page to see if the relevant Package Generation task reverts to false again.

 

If the issue persists:

  1. Start a Standard Procmon Capture.
  2. Log in to the Console and navigate to https://<ServerAddress>/support.php > Diagnostics and choose:
    • Snapshot Server Logs (to write current logs and start a new file)
    • Logging Duration: 30 minutes.
    • Debug Level: Verbose
    • Script Debug Level: Verbose
    • Click Start Logging
  3. Follow the steps above to Manually Test Regenerating Policy Installers.
  4. Navigate to https://<ServerAddress>/support.php > Diagnostics > Stop Logging Now.
  5. Complete the Procmon capture.
  6. Navigate to Tools > Requested Files > Diagnostic Files tab and save the files:
    • ServerLog-TIMESTAMP.bt9
    • ReporterLog-TIMESTAMP.log
    • PHPErrors-TIMESTAMP.log
  7. Zip the Procmon and Diagnostic Files together and upload to the Support case for further review.